﻿1
00:00:18,938 --> 00:00:22,101
END-TO-END Test

2
00:00:22,133 --> 00:00:33,498
End to End test is an approach used for protective schemes that consist of two or more relays that are in connection to exchange information related to trip and blocking.

3
00:00:33,523 --> 00:00:39,428
These schemes are used for more accurate detection of faults and faster isolation of the system.

4
00:00:39,453 --> 00:00:45,117
This test can be used to thoroughly analyze the protective scheme and make sure of its proper performance.

5
00:00:45,142 --> 00:00:51,085
In End to End tests, two or more test devices are used on each side to simulate the fault.

6
00:00:51,110 --> 00:00:55,734
To successfully perform an End to End test, the following elements are needed:

7
00:00:55,759 --> 00:00:57,820
•	A test device on each side

8
00:00:57,845 --> 00:01:02,282
•	A hardware piece to synchronize the two devices, like a GPS satellites.

9
00:01:02,307 --> 00:01:11,765
•	A file that is exported from the relay software to be used in the test device. This file can be of CSV, XRIO, TEXT or other formats.

10
00:01:11,790 --> 00:01:24,992
•	A communication equipment such as a phone or a two-way radio to communicate with the other post
With this introduction, we are going to analyze the software and hardware aspects of a longitudinal differential test on End to End platform.

11
00:01:25,017 --> 00:01:26,414
Hardware Preparation

12
00:01:26,439 --> 00:01:31,242
In hardware section, two test devices are needed for performing an End to End test.

13
00:01:31,267 --> 00:01:34,937
Each of these devices needs to be equipped with a GPS antenna.

14
00:01:34,962 --> 00:01:41,859
After examining the maps and isolating the piece of equipment for the test, the required inputs and outputs should be specified.

15
00:01:41,884 --> 00:01:48,125
For example, binary inputs AMT105 can be used to specify the pickup contact and trip.

16
00:01:48,150 --> 00:01:52,937
Binary outputs can be used in cases such as Circuit Breaker status simulation.

17
00:01:52,962 --> 00:02:01,867
In the next step, the test device voltage and current injection cables should be connected to the relay or test block to replace CT and PT for injecting the desired amounts.

18
00:02:01,892 --> 00:02:07,867
The GPS antenna is connected to the back of the device to use the GPS time as the base time.

19
00:02:07,892 --> 00:02:12,992
In End to End test, it is also possible to use other bases such as IRIG.

20
00:02:13,017 --> 00:02:18,250
To make sure that the breaker contact position is properly simulated by the test device,

21
00:02:18,275 --> 00:02:20,485
put the breakers in the right position.

22
00:02:20,510 --> 00:02:31,235
It should be noted that if other groups are working on the Circuit Breaker simultaneously, it is necessary to use the test plug to make sure that no trip is going to go on the Circuit Breaker.

23
00:02:31,260 --> 00:02:32,603
Software Preparation

24
00:02:32,628 --> 00:02:34,743
 In software section, before anything,

25
00:02:34,768 --> 00:02:46,452
it is necessary to connect to the relay and save the setting and config files as well as the records submitted for event and disturbance somewhere safe so that if there is a problem, they can be used as a backup.

26
00:02:46,477 --> 00:02:51,186
In the next step, export the file needed to enter the test device from the relay.

27
00:02:51,211 --> 00:02:58,764
As mentioned before, this file can be of different formats such as CSV, TEXT, XRIO, etc.

28
00:02:58,789 --> 00:03:03,975
An example for End to End test to analyze longitudinal differential protection

29
00:03:04,007 --> 00:03:13,967
Old longitudinal differential relays used the ratio of differential current to restrain current and if this ratio was higher than the specified settings,

30
00:03:13,992 --> 00:03:21,530
the trip was issued while in modern differential protective relays, a characteristic named alfa plain is used.

31
00:03:21,555 --> 00:03:30,561
In this design, the vector ratio of remote current to local for every current phase and negative and zero sequence currents are used.

32
00:03:30,586 --> 00:03:34,171
Here, to better present the End to End test method,

33
00:03:34,196 --> 00:03:41,983
a longitudinal differential protective test is performed on 7sd610 relays of Siemens Company.

34
00:03:42,008 --> 00:03:51,827
In this test, 7SD61 relays of Siemens with MLFB: 7SD61014BB990BJ0 and version 4.77 frameware is used.

35
00:03:51,852 --> 00:03:56,944
In the first step, we are going to review the prerequisites for performing the test described above.

36
00:03:56,969 --> 00:03:59,053
After making sure that everything is ready,

37
00:03:59,085 --> 00:04:09,581
first Vebko AMPro software is run and after ensuring that the laptop is connected to the amp105, the device IP is entered and the connection is made.

38
00:04:09,606 --> 00:04:20,324
Before beginning the test, it is suggested to ensure that the wiring is appropriate by injecting a current as big as 10 percent of the nominal current and reading the injected values from the relay.

39
00:04:20,349 --> 00:04:24,511
This can be done by simply clicking on “Test Hardware Congif” option.

40
00:04:24,536 --> 00:04:33,730
Then, the intended current must be specified in “Current Output” section, current injection channels are specified and the injection duration is selected.

41
00:04:33,755 --> 00:04:40,902
By clicking on the triangle at the top of the screen, the injection will keep going as long as the specified duration.

42
00:04:40,927 --> 00:04:45,871
The first part of the End to End test is related to ensuring stability or in other words,

43
00:04:45,841 --> 00:04:52,331
that if equal currents are injected from the two sides or in an external fault state, a trip is not issued.

44
00:04:52,356 --> 00:04:59,793
To test this state, “Sequencer” room is opened. At this point, the user needs to prepare the conditions for injecting values from both sides.

45
00:04:59,818 --> 00:05:07,863
It is possible to do so by selecting “Hardware Configuration” and specifying the two current groups in “Current Output Signal” section.

46
00:05:07,888 --> 00:05:18,902
Here, the first set is indicated by “IL1”, “IL2” and “IL3” which are located in front of X3, X1 and X2 elements, respectively.

47
00:05:18,927 --> 00:05:24,714
Now, the second set is activated in front of Y3, Y1 and Y2.

48
00:05:24,739 --> 00:05:33,910
To avoid confusion, it is better to change the values in front of X3, X1 and X2 to “Not Used” in “Voltage Output Signal” section.

49
00:05:33,935 --> 00:05:38,566
The intended inputs are activated in “Binary/Analog Input” header.

50
00:05:38,591 --> 00:05:42,144
By default, binary input 1 is set on the trip.

51
00:05:42,169 --> 00:05:48,527
For example, we set binary 2 for start and type “Start” phrase in front of “Label”.

52
00:05:48,957 --> 00:05:52,074
If the user wishes to adjust the output signal,

53
00:05:52,099 --> 00:05:58,339
for reasons such as specifying the state of the key, they can do so by using the binary output header.

54
00:05:58,364 --> 00:06:06,394
”Save last actual data” option in “Extra Settings” section can be used to save the last injection data.

55
00:06:06,645 --> 00:06:11,698
Since longitudinal differential test, especially in “Search” section,

56
00:06:11,723 --> 00:06:15,713
needs a long time and this can lead to overheating of the device,

57
00:06:15,738 --> 00:06:27,510
it is possible to activate “Maximum fan during test” option so that the fan works at its maximum speed during current injection and avoids overheating of the device and stopping the test.

58
00:06:27,535 --> 00:06:36,503
By clicking on “Test Object Parameters” and then clicking on “Device”, it is possible to enter information about the test such as the title of the test,

59
00:06:36,528 --> 00:06:44,971
the manufacturer company, the relay type, the primary and secondary voltages and some other information that are needed in the report.

60
00:06:44,996 --> 00:06:50,987
It should be noted that it is possible to add the information related to the rows at the left side of this window

61
00:06:51,012 --> 00:06:59,182
after performing the test but the information related to the rows at the right side must be specified before initiating the test.

62
00:06:59,207 --> 00:07:08,315
In the next step, the current value is to be entered in accordance with the differential settings as well as the turns ratio and CT polarity of the sides.

63
00:07:08,340 --> 00:07:25,268
For example, suppose that the line current is 100 amps and the CT conversion ratio of the primary side is 600 to 1 while the turns ratio of the other side is 800 to 1 and the polarity is set at “Toward.Prot.Obj”  for both sides.

64
00:07:25,293 --> 00:07:33,033
It is possible to perform mathematical operations in all cells of the Vebko software without the need to use a calculator.

65
00:07:33,058 --> 00:07:38,822
By entering a value in a cell and right-clicking on it and then selecting “Equal Magnitudes” option,

66
00:07:38,847 --> 00:07:43,236
it is possible to enter the same value in all cells of a current injection side

67
00:07:43,275 --> 00:07:45,986
Then the same process can be repeated for the other side.

68
00:07:46,011 --> 00:07:55,541
Now, since during a stability test the currents on both sides need to be equal in accordance with the CT turns ratio and have a 180 degree difference,

69
00:07:55,566 --> 00:08:02,447
the currents from one side are taken as the basis and a 180 degree difference is considered for currents from the other side.

70
00:08:02,472 --> 00:08:10,196
To do so, the current angle of one of the cells is entered and “Balance angle” option is used to apply the angle difference for the other phases.

71
00:08:10,221 --> 00:08:15,408
It is possible to view the amount and direction of the current values in “Vector View” window.

72
00:08:15,433 --> 00:08:21,018
It should be noted that in “Signal View” window it is possible to view the applied changes instantly.

73
00:08:21,043 --> 00:08:30,018
By default, the currents are considered momentary but it is possible to select average values by selecting “Setting” header and then “RMS” option.

74
00:08:30,113 --> 00:08:40,182
If the stability test is only applied for one phase, it is possible to mark the checkbox for the corresponding phase so that only the signals related to that phase are displayed.

75
00:08:40,207 --> 00:08:43,650
In the next step, the test start conditions are adjusted.

76
00:08:43,675 --> 00:08:49,221
In this section, by selecting “Start Condition Repetition” option, a new page opens.

77
00:08:49,706 --> 00:08:56,775
In “Start Test Condition” section, the third option is related to the coordination of GPS for initiating the test.

78
00:08:56,800 --> 00:09:05,274
“Start Time” and “Next Full” options are related to the start time of the test and the duration of pause before every injection, respectively.

79
00:09:05,299 --> 00:09:11,407
If “Next full” option is unchecked, the injections will be done repeatedly and without any pause.

80
00:09:11,432 --> 00:09:18,141
In this section, a time should be specified as the test start time in coordination with the other side which is remote post.

81
00:09:18,166 --> 00:09:25,211
Before anything, it is necessary to ensure that the device and the GPS are synchronized by clicking on “Start Sync” option.

82
00:09:25,236 --> 00:09:35,386
If the user is using a 32-bit windows, clicking on “Set Windows Time with GPS” option, will cause the computer clock to be synchronized with the GPS.

83
00:09:35,411 --> 00:09:42,143
In “Data” section it is possible to view the information including the GPS time and latitude and longitude.

84
00:09:42,139 --> 00:09:54,026
Also, in “Satellite signal level” and “Satellite signal level history” section, it is possible to view other information related to the power and intensity of the signals received from the GPS.

85
00:09:54,051 --> 00:09:59,151
After applying the settings, by clicking on “Start” the test beings at the specified time.

86
00:09:59,176 --> 00:10:04,900
By applying these settings, it is possible to start current injection and ensure the stability of the condition.

87
00:10:04,925 --> 00:10:10,173
In the end, the file is saved and by selecting “Parameters” menu and then clicking on “Report”,

88
00:10:10,209 --> 00:10:15,634
after selecting the elements that are going to be added to the report, “Ok” option is selected.

89
00:10:15,659 --> 00:10:21,985
This will open the “Report” header so that by using the “Export Report” option or pressing “CTRL+P” keys,

90
00:10:22,010 --> 00:10:25,040
the report can be printed or saved as a file.

91
00:10:25,073 --> 00:10:29,462
It is worth mentioning that if the user is using a PDF management software,

92
00:10:29,487 --> 00:10:38,267
it is better for them to use “CTRL+P” shortcut so that the gap between the pages is removed and the report looks more well-organized.

93
00:10:38,292 --> 00:10:43,564
In the next step, “AMT Differential” room is used to perform the main test.

94
00:10:43,589 --> 00:10:52,493
Here, “Hardware Configuration” page is opened and the currents of the remote side or the other post are set at “Not Used” in “Output Target” section.

95
00:10:52,518 --> 00:11:02,626
It is also possible to save this combination of current channels by clicking on “Export” option at the bottom of the screen to use it in future tests.

96
00:11:03,701 --> 00:11:14,759
Now, by clicking on “Test Object Parameters” option, “Import from list” option from the “File” menu or the icon labeled “L” letter is selected.

97
00:11:14,784 --> 00:11:25,829
In this section, by entering the relay name in “Search” box, it is possible to select the XRIO or RIO corresponding to that relay and the software version.

98
00:11:25,873 --> 00:11:29,415
Here “7SD61” is entered.

99
00:11:29,440 --> 00:11:36,251
By double-clicking on the related “XRIO”, “File” menu and then “Load Relay Setting” is selected.

100
00:11:36,276 --> 00:11:44,659
In “Relay Config Type” section, the configuration type received from the relay is selected which is different for every brand.

101
00:11:44,684 --> 00:11:50,095
In “Config File Path” section, the path of this file is given to the software.

102
00:11:50,120 --> 00:11:56,259
Here, we are receiving the XRIO file using DIGSI 4 software of Siemens Company.

103
00:11:56,284 --> 00:11:57,962
By clicking on “Ok”,

104
00:11:57,987 --> 00:12:06,024
it is necessary to ensure that the relay parameters are entered correctly by viewing the number located in front of “Parameter Values Imported”.

105
00:12:06,049 --> 00:12:12,860
By clicking on “Ok” and closing the windows, the graph will be entered to the differential characteristic window.

106
00:12:12,885 --> 00:12:23,149
Before beginning the test, the “Test Object Parameters” window is opened again and “7SD61” subcategory is opened by clicking on the plus sign.

107
00:12:23,174 --> 00:12:32,103
In “Relay Parameter Section (Local Relay)” it is possible to view the information related to the local relay or the current post in different subcategories.

108
00:12:32,265 --> 00:12:38,131
In subcategory “Setting Group A”, it is possible to view the settings of different functions.

109
00:12:38,156 --> 00:12:44,726
By going to subcategory “87 DIFF PROT”, it is possible to examine the activity status of this parameter,

110
00:12:44,751 --> 00:12:51,461
time and current settings of pickup and trip, the inrush settings and the parameter related to the charge of the line.

111
00:12:51,601 --> 00:12:58,079
In “Relay parameter section (Remote relay)” section, it is possible to view the information related to the relay of the opposite post.

112
00:12:58,104 --> 00:13:05,719
Here, parameters with a green check mark in “State” section in front of them are the elements that are active in the relay of the opposite side.

113
00:13:05,744 --> 00:13:11,915
. In this section, it is possible to receive the information about the relay of the opposite side from the setting file,

114
00:13:11,940 --> 00:13:18,891
xml file or even orally from the operator of the remote post and enter it into the “Value” field.

115
00:13:18,916 --> 00:13:25,868
Now, once more, “Test Object Parameter” is selected and “Line Differential” block is opened by double-clicking on it.

116
00:13:25,893 --> 00:13:35,360
The important point here is that the values entered for primary and secondary in “Protected Object” section must be the same in both local and remote posts.

117
00:13:35,385 --> 00:13:43,594
Also, these values need to be reviewed especially in “CT Nominal Values” section to ensure that the turn’s ratios are correct.

118
00:13:43,619 --> 00:13:52,469
Also, it is possible to view the test status graphically along with the parameters on it by opening “Medium Detail View” window from the “View” menu.

119
00:13:52,494 --> 00:13:56,227
After finishing this stage, it is time to perform different tests.

120
00:13:56,252 --> 00:14:01,375
To start, “On GPS” option is selected after selecting “Start Condition Repetition”.

121
00:14:01,400 --> 00:14:10,594
In this section, by clicking on “Start sync”, the satellite signals are detected and the time synchronization is done which may take up to few minutes.

122
00:14:10,619 --> 00:14:16,383
It should be noted that, usually, Shot Test and Search Test are performed in this Room and the first examines the action

123
00:14:16,415 --> 00:14:18,703
or inaction in Trip and No Trip areas,

124
00:14:18,712 --> 00:14:31,774
respectively and the second test determines the border between Tripping and No Trip areas by interpolating the points so that the user can have a scale of the curve drawn in this environment as well as the real operation of the relay.

125
00:14:31,799 --> 00:14:35,781
In the next step, after coordinating with the opposite side,

126
00:14:35,805 --> 00:14:40,508
some points are put on the differential characteristic and after adding them to the test table,

127
00:14:40,540 --> 00:14:48,540
it is possible to compare their coordination which is a combination of “ibias” and “idff” to ensure that the conditions are the same.

128
00:14:48,565 --> 00:14:53,422
By clicking on the cog icon at the bottom of the differential characteristic window,

129
00:14:53,402 --> 00:14:58,063
it is possible to use the features that help the user to better supervise the test.

130
00:14:58,149 --> 00:15:02,860
Now, by returning to “Start Condition” tab, in “On GPS” section,

131
00:15:02,985 --> 00:15:10,531
a time is considered as the start time after coordination with the opposite side and then by unchecking “Next full”

132
00:15:10,546 --> 00:15:15,914
option whose function has been explained before, the test is initiated.

133
00:15:57,001 --> 00:16:03,852
To perform the “Search Test”, first, it is necessary to draw lines called “Search Line” in different parts of the vector.

134
00:16:03,936 --> 00:16:09,953
To draw a “Search Line”, the user can hold the “CTRL” button and left-click of the mouse on “Differential Characteristic”

135
00:16:09,978 --> 00:16:14,227
window and then move the cursor on the characteristic curve as intended

136
00:16:14,266 --> 00:16:19,875
It can be seen that the information regarding the drawn “Search Line” is displayed in “Search Test” lines table.

137
00:16:19,900 --> 00:16:30,430
After drawing these lines, it is necessary to share the information of these lines with the other side so that the drawn lines are exactly the same on both sides and they both have the same order.

138
00:16:30,455 --> 00:16:36,047
After drawing the “Search Line” and adjusting the settings in “Start-condition” window, by starting the test,

139
00:16:36,016 --> 00:16:45,883
the software starts interpolating the characteristic curve by testing several points on the search line and then determines the exact location of the characteristic curve.

140
00:17:31,313 --> 00:17:36,367
After the test is finished and the file is saved, by selecting “Parameters”,

141
00:17:36,392 --> 00:17:45,583
the “Report Setting” window is opened and the parameters that need to be added to the report are selected so that the results can be saved as an output file.

